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Before You Begin 

____________________________________  

The JADE Dump and Load Utility User’s Guide is intended as the main source of information when 
you are dumping and loading data for deployed JADE user applications. 

Who Should Read this Guide  
The main audience of the JADE Dump and Load Utility User’s Guide is expected to be system 
administrators.   

Related Documentation 
Other documents that are referred to in this guide, or that may be helpful, are listed in the 
following table, with an indication of the JADE operation or tasks to which they relate.   

Title Related to… 

JADE Database Administration Guide Administering JADE databases 

JADE Development Environment Administration Guide Administering JADE development environments 

JADE Development Environment User’s Guide Using the JADE development environment 

JADE Installation and Configuration Guide Installing and configuring JADE 

JADE Initialization File Reference Maintaining JADE initialization file parameter values 

JADE Runtime Application Guide Administering deployed JADE runtime applications 

JADE Thin Client Guide Administering JADE thin client environments 

Terminology 
In this document, the term Microsoft Windows refers to Windows 2003 Server, Windows Vista, 
Windows XP, Windows 2000, or Windows CE.  When there are differences between the versions of 
Microsoft Windows, the specific version of Microsoft Windows is stated.  This also applies to Linux, 
which is a specific version of UNIX developed by SUSE or Red Hat.  The term UNIX is used when 
an issue is generic to all versions of UNIX and the term Linux is used if the issue is specific to the 
SUSE or Red Hat implementation of UNIX.   

With the exception of the jade.exe program, when referring to Windows program executables in 
this document, the .exe file suffix is omitted; for example, jadclient refers to jadclient.exe on 
Windows and jadclient.sh on UNIX.  Similarly, the Windows .dll (Dynamic Link Library) and 
UNIX .so (shared object library) file suffixes are omitted.  For example, jomos refers to jomos.dll 
(Windows) and libjomos.so (Linux). 
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Conventions  
The JADE Dump and Load Utility User’s Guide uses consistent typographic conventions throughout. 

Convention Description 

Arrow bullet (¾) Step-by-step procedures.  You can complete procedural instructions by using either the mouse or 
the keyboard. 

Bold Items that must be typed exactly as shown.  For example, if instructed to type foreach, type all the 
bold characters exactly as they are printed. 

 File, class, primitive type, method, and property names, menu commands, and dialog controls are 
also shown in bold type, as well as literal values stored, tested for, and sent by JADE instructions. 

Italic Parameter values or placeholders for information that must be provided; for example, if instructed 
to enter class-name, type the actual name of the class instead of the word or words shown in italic 
type. 

 Italic type also signals a new term.  An explanation accompanies the italicized type. 

 Document titles and status and error messages are also shown in italic type. 

Blue text Enables you to click anywhere on the cross-reference text (the cursor symbol changes from an 
open hand to a hand with the index finger extended) to take you straight to that topic.  For example, 
click on the “Before You Dump or Load Your User Data” cross-reference to display that topic.   

Bracket symbols ( [ ] )  Indicate optional items. 

Vertical bar ( | )  Separates alternative items. 

Monospaced font Syntax, code examples, and error and status message text. 

ALL CAPITALS Directory names, commands, and acronyms. 

SMALL CAPITALS Keyboard keys. 

Key combinations and key sequences appear as follows. 

Convention Description 

KEY1+KEY2 Press and hold down the first key and then press the second key.  For example, “press SHIFT+F2” 
means to press and hold down the SHIFT key and press the F2 key.  Then release both keys. 

KEY1,KEY2 Press and release the first key, then press and release the second key.  For example, “press 
ALT+F,X” means to hold down the ALT key, press the F key, and then release both keys before 
pressing and releasing the X key. 
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Chapter 1     Dumping User Data and Loading 
it into Another Database 

____________________________________  

This document covers the following topics.   

� Overview 

� Dump and Load Utility Considerations 

� Before You Dump or Load Your User Data 

� Running the Dump and Load Utility 

� Using the Dump and Load Windows Utility 

� Running the Dump and Load Utility in Batch Mode 

Overview 
The Dump and Load utility ( jddlutl) is supplied with your JADE release, to enable you to transfer 
your user data from one version of JADE to another where direct file copying is neither 
appropriate nor possible.   

To convert your data, you should use the JadeConvertDb application in the jadclient program.  
For details, see Chapter 4, “Converting a User Database”, in the JADE Runtime Application Guide. 

The JADE Dump Load Utility icon is installed in your JADE program folder when you install 
JADE.  For details, see “Installing Your JADE Software”, in Chapter 1 of your JADE Installation and 
Configuration Guide. 

The Dump and Load utility can be run as a standalone Windows utility or in batch mode (for 
example, from a command script when loading user data on a UNIX platform).  For details, see 
“Running the Dump and Load Utility” or “Running the Dump and Load Utility in Batch Mode”, 
later in this document. 

Use the Dump and Load utility in the following circumstances. 

� Transferring user data from one platform to another. 

With the availability of the UNIX version of JADE, you may need to transfer your user data 
from a Windows 2003 Server-based, Windows Vista-based, Windows XP-based, or Windows 
2000-based server to a UNIX Linux-based server or the reverse.  As the database files for these 
two platforms are not compatible, the Dump and Load utility provides the mechanism to do 
this.   

� Transferring user data between an ANSI version and a Unicode version of JADE or the 
reverse, where the database files are incompatible.   



JADE Dump and Load Utility  
User’s Guide 

Chapter 1    Dumping User Data and Loading it into Another Database  7 

DumpLoad-6.3 

� Transporting data in a platform-independent form for initial deployment, instead of copying 
the user data files.  The Dump and Load utility transfers only your user data.   

Notes   As the transfer of data may run for a significant period and be subject to unexpected 
problems such as disk space exhaustion, you can halt the dump or load process and restart it at the 
point at which it halted, if required. 

The dump and load processes can be run in parallel as two discrete processes.  This utility can be 
run in local single user or remote single user mode only.  Remote multiuser mode is not 
supported. 

The Dump and Load utility can be run over a deployed runtime JADE system. 

Dump and Load Utility Considerations 
When using the Dump and Load utility: 

� Object editions are not preserved during the dump and load processes. 

� The creation times are set to the date and time of the creation of the object during the load 
process. 

� You cannot rename classes or properties when loading your user data. 

� To ensure the integrity of the transfer mechanism, you must dump and reload your entire 
database.  (Partial dumping and loading is not supported in any form.) 

� As the extraction of database contents into a more-easily read ASCII format may pose security 
issues for some sites and applications, file system security is used to protect the dumped files 
and to restrict access to the Dump and Load utility itself.   

There are no encryption hooks for the Dump and Load utility in this release. 

� If you are using the Dump and Load utility to transfer your user data between Windows and 
UNIX Linux environments, a communication mechanism for transferring the data must exist 
between the two platforms; for example, files.   

You can use Network File System (NFS) or SAMBA to share files between Windows and 
UNIX, as both protocols allow read and write updating of the control file by both ends.   

With NFS, either the Windows or the UNIX environment can act as the disk server, 
depending on the platform on which it is installed.  With SAMBA, only the UNIX 
environment can act as the disk server.   

Note   You must map common UNIX to Windows directories for your transfer data output 
files, and any specified paths must be server-relative. 

The Windows dump or load process ( jddlutl) on UNIX platforms cannot be run in local 
single user mode but must be run in remote single user mode.  However, you can run this 
utility in local single user mode by using the batch jddlutlb executable program.   

As UNIX uses different carriage return and linefeed (Cr/Lf) conventions from those of 
Windows for ASCII files, a single linefeed (Lf) character is used to mark the end of line.   

� Your user data is not filtered or initialized during the dump and load processes. 
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Before You Dump or Load Your User Data 
Before you run the Dump and Load utility to transfer your user data, you must first: 

1. Check in all checked out methods. 

2. Perform any reorganization of your database that is required.  (As the schema for the system 
being dumped must be identical to that of the system being reloaded, an error is raised if 
reorganization is outstanding.) 

3. If you are going to dump a large amount of user data, use the JADE Database utility to certify 
and compact your database.   

4. Back up your existing database. 

For details, see “Backups”, in Chapter 3 of your JADE Database Administration Guide. 

5. Extract and load your schema and form file definitions (.scm and .ddb files) by using the 
JADE development environment Extract and Load commands from the Schema menu or the 
Schema Load utility.   

Caution   The Dump and Load utility does not extract your schema and form file definitions 
(.scm and .ddb files), nor does it load them before the user data load process. 

Running the Dump and Load Utility 
The dump process reads all instances of your user data in the specified JADE database and writes 
them to data files in the transfer directory in an ASCII format.   

The dump process starts by opening the specified database and then builds a list of all schemas, 
classes, and database files that need to be dumped.  It then dumps this schema information to assist 
the load process, before dumping your user data in the following phases. 

1. Dumps the properties of non-collection instances 

2. Dumps the properties of shared collection instances 

3. Dumps the properties of exclusive collection instances 

4. Dumps the keys and members of shared collection instances 

5. Dumps the keys and members of exclusive collection instances 

Each phase consists of one or more steps, with each step consisting of dumping the instances of a 
class in a database file.  The dump process is complete when all phases have been performed for all 
of your user data classes in the system.   

A control file in your transfer data directory (control.dmp) is updated between each step, to allow 
the load process to synchronize with the dump process.  The dump process can be restarted at the 
start of each step if it failed for any reason during that step.   

The process automatically restarts from the appropriate step the next time it is run.   

All informational messages, warnings, and error messages are logged in the log file dump.log 
located in the transfer data directory. 
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Note   No attempt is made to check that there is enough disk space to perform the entire dump 
operation. 

The load process reads all ASCII data files produced by the dump process and reconstructs the 
instances in the specified new JADE database.  The process starts by polling the control file to see 
if the dump process has started, and builds a list from the dumped schema information of all 
schemas, classes, and database files that are to be loaded.  It then loads each ASCII data file in turn, 
mimicking the phases of the dump process.   

The target database into which the transferred user data is to be loaded must not contain user 
data.   

The load process is complete when the dump process has also completed and all ASCII data files 
have been loaded.  The load process can be restarted at the beginning of each ASCII data file step 
if it failed for any reason during that step.  The load process automatically restarts from the 
appropriate step the next time it is run.   

All informational messages, warnings, and error messages are logged in the load.log log file in the 
specified transfer data directory. 

Using the Dump and Load Windows Utility 
The jddlutl Dump and Load utility is a standalone Windows utility that is used for initiating the 
dump or load of your user data.   

To initiate the Dump and Load utility, ensure that the correct path is specified in the command 
line for the Dump and Load utility, as shown in the following example. 

d:\jade\bin\jddlutl transferDir=d:\jade\testdata path=d:\jade\system 
ini=d:\jade\system\jade.ini server=singleUser displayTimes=true 

The syntax of the Dump and Load utility is: 

jddlutl transferDir=transfer-data-directory-path  
        path=database-path  
        ini=initialization-file-name  
        [server=server-mode]         // singleUser or remoteSingleUser 
        [displayTimes=boolean] 

¾ To initiate the Dump and Load utility 

1. Ensure that you have a full backup of your database. 

2. Perform one of the following actions. 

� Select the JADE Dump Load Utility program icon from your JADE program folder. 

� In Explorer or File Manager, access the directory in which your JADE binary files are 
located (for example, c:\ jade\bin) and then double-click on the jddlutl program file.  

The JADE Data Dump Load Utility window is then displayed. 

Although you can run the dump and the load processes in parallel, each process must have its own 
executable program.  You would therefore: 

1. Invoke the Dump and Load utility on the platform containing your source user data. 
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2. Select the Dump Data command from the File menu to specify your dump parameters and 
then initiate the dump process. 

3. Invoke the Dump and Load utility on the target platform for your loaded user data. 

4. Select the Load Data command from the File menu to specify your load parameters and then 
initiate the load process. 

Using the JADE Data Dump Load Utility Window 
The JADE Data Dump Load Utility window consists of a: 

� Menu bar, containing the following menus. 

� File 

� Options 

� Help 

For details, see the following subsections. 

� Main display area, which has a dump mode and a load mode 

This area is used to display informational messages, warnings, and errors during the dump or 
load process.  The time and date of the message, its type, and the text of the message are 
output in a logging style. 

� Status line 

The status line at the lower left of the window displays immediate status information about 
the dump or load process; for example, it usually displays the approximate percentage 
completed of the entire dump or load process. 

� Progress bar 

The progress bar at the bottom of the window displays the approximate percentage 
completed of the current step of the dump or load process.  (This percentage corresponds to 
the processing required to dump or load a transfer file of your user data.) 

� Cancel button 

The Cancel button is enabled during the dump or load process, to enable you to stop the 
current process.  When you click this button, the current step is aborted.   

When you next select the appropriate File menu command to start that process, it is restarted 
from the beginning of the step at which the processing was halted.  The appropriate dump or 
load parameters dialog is redisplayed, to enable you to click the applicable Dump button or 
Load button to restart the process.   

The Transfer Directory text box is ignored, as the process is restarted using the previous 
values for the parameter with which the process was halted.  
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Using the File Menu 
Use the File menu in the JADE Data Dump Load Utility window to perform the actions listed in 
the following table. 

Menu Command Action 

Dump Data Displays the Dump Parameters dialog 

Load Data Displays the Load Parameters dialog 

Clear Display Clears the running display of messages output to the window 

Exit Exits from the Dump and Load utility 

These menu commands are described in the following subsections. 

Dump Data Command 

Select the Dump Data command from the JADE Data Dump Load Utility window File menu to 
display the Dump Parameters dialog that enables you to specify your options for the dumping of 
your user data.   

For details, see “Dumping User Data”, later in this document. 

Load Data Command 

Select the Load Data command from the JADE Data Dump Load Utility window File menu to 
display the Load Parameters dialog that enables you to specify your options for the loading of your 
user data.   

For details, see “Loading User Data”, later in this document. 

Clear Display Command 

Select the Clear Display command from the JADE Data Dump Load Utility window File menu to 
clear the running display of dump or load messages output to the JADE Data Dump Load Utility 
window. 

When you run a Dump and Load utility operation, a running display of output messages is 
optionally produced in your JADE Data Dump Load Utility window.   

This display provides informational messages, warnings, and errors that occur during the phases of 
the dump or load process.  You can optionally display the time and date of each message.   

For details about enabling or disabling the display of messages and dates and times, see “Specifying 
Your Display Options”, later in this document. 

Note   Regardless of the enabling or disabling of the message display, this information is output to 
the dump.log or load.log files located in your specified transfer data directory.  (For details, see 
“Dumping User Data” and “Loading User Data”, later in this document.) 

¾ To clear the running display 

� Select the Clear Display command on the File menu. 

Exit Command 

Use the Exit command from the File menu to exit from the Dump and Load utility.   
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Your log files are not removed from the transfer data directory when you from exit from the Dump 
and Load utility.  You should therefore delete them manually when you have finished using them.   

¾ To exit from the Dump and Load utility 

� Select the Exit command from the File menu. 

You can also exit from the JADE Data Dump Load Utility window by clicking the close icon 
(⌧) at the top right corner of the window, or by selecting the Close command from the 
Control-Menu. 

The JADE Data Dump Load Utility window is then closed. 

Using the Options Menu 
Use the Options menu in the JADE Data Dump Load Utility window to change the options 
associated with displaying output messages in the window during the dump and load processes. 

The Options menu provides the Preferences command, described in the following subsection. 

Preferences Command 

The Preferences command from the JADE Data Dump Load Utility window Options menu 
enables you to specify your JADE Data Dump Load Utility window viewing preferences.   

For details about setting the display in your JADE Data Dump Load Utility window, see “Specifying 
Your Display Options”, in the following subsection. 

Specifying Your Display Options 

¾ To specify your JADE Data Dump Load Utility window display preferences 

1. Select the Preferences command from the Options menu. 

The Display Preferences dialog, shown in the following diagram, is then displayed. 

 

2. Uncheck the Display Informational Messages check box if you do not want all informational 
messages from the dump and load process phases displayed in your JADE Data Dump Load 
Utility window as well as any warning or error message that is raised.   

As a large number of information-only messages may be produced, you can use this check 
box to hide their display and therefore allow warning and error messages to be observed 
more easily.   

Informational messages are output to the appropriate dump.log and load.log files in your 
specified transfer data directory, regardless of the setting of this check box.  Informational 
messages are output to the window by default. 
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3. Uncheck the Display Date / Time check box if you do not want date and time information 
output with messages displayed in the JADE Data Dump Load Utility window.  When this 
check box is unchecked to hide the display of date and time information, more room is 
provided in the main display area of the JADE Data Dump Load Utility window for messages.   

Date and time information is output to the appropriate dump.log and load.log files in your 
specified transfer data directory, regardless of the setting of this check box.  Date and time 
information is output to the window by default. 

4. If you do not want the default of 1000 lines output to the main display area of the window 
before the display is automatically cleared and the display then restarted from the top, specify 
the maximum number of displayed lines that you require. 

5. Click the Font button if you want to change the default display font from System, Bold, and 
12 points.  The common Font dialog is then displayed, to enable you to make your font 
selections.   

6. Click the OK button to confirm your selections, or the Cancel button to discard your 
selections.   

Your current settings are then changed.   

Using the Help Menu 
Use the About command in the Help menu to access the information about the Dump and Load 
utility.  This command is described in the following subsection. 

About Command 

The Dump and Load utility Help menu About command accesses information about the utility.  
This information includes the JADE release version and copyright information. 

¾ To access the Dump and Load utility information 

� Select the About command from the Help menu 

The About box is then displayed.  This dialog is for display purposes only. 

Dumping User Data 

¾ To dump your user data from your source platform or node 

1. Ensure that your user data is ready to be transferred and that you have specified any display 
options that you require.   

For details, see “Before You Dump or Load Your User Data”, earlier in this document. 

2. Select the Dump Data command from the File menu in the JADE Data Dump Load Utility 
window. 
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3. The Dump Parameters dialog, displayed in the following diagram, is then displayed. 

 

4. In the Database Path text box, specify the full path in which your database files are located.  
The database path must exist. 

If you are unsure of your database directory, click the adjacent browse button (indicated by 
the … points of ellipsis symbol) to display the common Directory Selection dialog that 
enables you to select the database path in which your user data is located. 

If you have previously run the dump process in the current JADE release, the database path 
that you used last time you dumped your user data is displayed in this text box.   

5. In the Ini File Name text box, specify the full path and the name of your JADE initialization 
file if it is located in a directory other than the database directory or it has a name other than 
the jade.ini default.  The initialization path and file must exist. 

If you are unsure of your initialization file, click the adjacent browse button (indicated by the 
… points of ellipsis symbol) to display the common File Selection dialog that enables you to 
select the initialization file that is used. 

6. In the Server Type combo box, select the mode in which you want to dump your user data; 
that is, in SingleUser (local) or SingleUser (remote) mode.  By default, user data is dumped 
in single user local mode. 

If you have previously run the dump process in the current JADE release, the server mode in 
which your user data was last dumped is displayed. 

7. In the Transfer Directory text box, specify the full path of the directory into which your user 
data is to be written.  The transfer data directory must exist. 

If you are unsure of your transfer directory, click the adjacent browse button (indicated by 
the … points of ellipsis symbol) to display the common Directory Selection dialog that 
enables you to select the transfer directory in which your user data is to be dumped. 

If you have previously run the dump process in the current JADE release, the transfer 
directory into which your user data was last written to and read from is displayed. 

8. Click the Dump button to: 

a. Validate your specified parameters 

b. Store them in the [ JadeDumpLoad] section of your specified initialization file 

c. Close the dialog 

d. Initiate the dump process 



JADE Dump and Load Utility  
User’s Guide 

Chapter 1    Dumping User Data and Loading it into Another Database  15 

DumpLoad-6.3 

For details about the [ JadeDumpLoad] section, see “User Data Dump and Load Section 
[ JadeDumpLoad]”, in your JADE Initialization File Reference. 

Alternatively, click the Cancel button to discard your selections. 

When you have initiated the dumping of your user data from the database to your specified 
transfer data directory, the main display area of the JADE Data Dump Load Utility window then 
displays informational messages, warnings, and errors during the dump process. 

The time and date of the message, its type, and the text of the message are output in a logging 
style, which you can tailor by using the Display Preferences dialog.  (For details, see “Specifying 
Your Display Options”, earlier in this document.)   

An example of the JADE Data Dump Load Utility window in dump mode is shown in the following 
diagram. 

 

Click the Cancel button at any time during the dump process if you want to stop the current 
process.  The current step is then aborted.   

When you next select the Dump Data command from the File menu to start that process, it is 
restarted from the beginning of the step at which the dump processing was halted.  (The Dump 
Parameters dialog is redisplayed, to enable you to click the Dump button to restart the dump 
process.  The Transfer Directory text box is ignored, as the dump process is restarted using the 
previous value for this parameter with which the process was halted.)   
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Tip   When you have started dumping your user data, you can then invoke another Dump and 
Load utility application and initiate the loading of that data as each step in the dump process 
phase completes.  For details, see “Loading User Data”, in the following section. 

Loading User Data 

¾ To load your user data to your target platform or node 

1. Ensure that your user data has already been dumped to your transfer data directory or that 
you have already started the dump process on your source platform or node.   

For details, see “Dumping User Data”, earlier in this document. 

If your user data is currently being dumped and you are loading it into a directory on the 
same node (for example, from one JADE release to another), select the JADE Dump Load 
Utility program icon from your JADE program folder again, to invoke another Dump and 
Load utility application. 

Tip   For better performance, run the dump and load processes on separate workstations so 
that both processes will then not have to share the same Central Processing Unit (CPU). 

2. Select the Load Data command from the File menu in the JADE Data Dump Load Utility 
window. 

3. The Load Parameters dialog, displayed in the following diagram, is then displayed. 

 

4. In the Database Path text box, specify the full path in which your database files are located 
and to which your transferred user data is to be written.  The database path must exist, and it 
cannot contain user data.   

If you are unsure of your database directory, click the adjacent browse button (indicated by 
the … points of ellipsis symbol) to display the common Directory Selection dialog that 
enables you to select the database path to which your user data is to be written.  If you have 
previously run the load process in the current JADE release, the database path that you used 
last time you loaded your user data is displayed in this text box. 

5. In the Ini File Name text box, specify the full path and the name of your JADE initialization 
file if it is located in a directory other than the database directory or it has a name other than 
the jade.ini default.  The initialization path and file must exist.  
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If you are unsure of your initialization file, click the adjacent browse button (indicated by the 
… points of ellipsis symbol) to display the common File Selection dialog that enables you to 
select the initialization file that is used. 

6. In the Server Type combo box, select the mode in which you want to load your user data 
(that is, in SingleUser (local) or SingleUser (remote) mode).  By default, user data is loaded 
in single user local mode.  If you have previously run the load process in the current JADE 
release, the server mode in which your user data was last loaded is displayed.   

7. In the Transfer Directory text box, specify the full path of the directory into which your user 
data was dumped in preparation for the load process.  The transfer directory must exist.   

If you are unsure of your transfer directory, click the adjacent browse button (indicated by 
the … points of ellipsis symbol) to display the common Directory Selection dialog that 
enables you to select the transfer directory from which your user data is to be loaded.   

If you have previously run the load process in the current JADE release, the transfer directory 
in which your user data was last written to and read from is displayed. 

8. Click the Load button to: 

a. Validate your specified parameters 

b. Store them in the [ JadeDumpLoad] section of your specified initialization file 

c. Close the dialog 

d. Initiate the load process 

For details about the [ JadeDumpLoad] section, see “User Data Dump and Load Section  
[ JadeDumpLoad]”, in your JADE Initialization File Reference.)  Alternatively, click the Cancel 
button to discard your selections. 

When you have initiated the loading of your user data from the specified transfer data directory, 
the main display area of the JADE Data Dump Load Utility window then displays informational 
messages, warnings, and errors during the load process.   

The load process checks that your specified target database into which the transferred user data is 
to be loaded contains no existing user data.  If existing user data is detected, an exception is raised 
and the load process cannot commence until you have removed existing user data from that 
database. 

The time and date of the message, its type, and the text of the message are output in a logging 
style, which you can tailor by using the Display Preferences dialog.  (For details, see “Specifying 
Your Display Options”, earlier in this document.)   
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An example of this window in load mode is shown in the following diagram. 

 

Click the Cancel button at any time during the load process if you want to stop the current process.  
The current step is then aborted.   

When you next select the Load Data command from the File menu to start that process, it is 
restarted from the beginning of the step at which the load processing was halted.  (The Load 
Parameters dialog is redisplayed, to enable you to click the Load button to restart the load process.  
The Transfer Directory text box is ignored, as the load process is restarted using the previous 
values for those parameters with which the process was halted.)   

The following warning message is displayed if the load process reaches a step in the dump process 
that has not yet completed.   

Waiting for dump of process-state for class schema-name / class-name to 
complete 

This may indicate that the dump process has been halted by using the Cancel button or that the 
load is waiting for large a dump step to be actioned.  The load process resumes when that step in 
the dump process has been completed. 

Running the Dump and Load Utility in Batch Mode 
The jddlutlb program, installed with your JADE software, enables you to automate the Dump and 
Load utility by running it in batch mode.   
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Run the batch Dump and Load utility (for example, from a command script when loading user 
data in single user mode on a UNIX platform), specifying the following. 

jddlutlb action=operation-type 
         transferDir=transfer-data-directory-path 
         path=database-path  
         ini=initialization-file-name  
         [server=server-mode] 
         [displayTimes=boolean] 
         [help] 

The following is an example of the command for dumping test user data. 

d:\jade\bin\jddlutlb action=dump transferDir=d:\jade\testdata 
path=d:\jade\system ini=d:\jade\system\jade.ini server=remoteSingleUser 
displayTimes=true 

The batch Dump and Load utility program displays a progress report of each phase of the dump or 
load process.  Standard dump or load information is output to stdout and error information is 
output to stderr.  At the end of the dump or load operation, the running display provides a 
completion report.  For details about displaying and redirecting the output from JADE batch 
utilities, see the DisplayApplicationMessages, LogServer, and UseLogServer parameters under 
“JADE Log Section [ JadeLog]”, in your JADE Initialization File Reference. 

If the jddlutlb executable program fails, a non-zero exit code is returned and an error message is 
displayed; for example, if the database directory was invalid.   

Notes   If the program stops for any reason (for example, it runs out of disk space), although you 
cannot manually halt a batch dump or load process, it restarts from the beginning of the step at 
which it halted when you next run that dump or load batch program. 

To run this on UNIX under SUSE Linux Enterprise Server or the Red Hat distribution of Linux, 
use the jddlutlb command line parameters described in this section and ensure that the standard 
JADE environment variables (documented under “Required Environment Variables”, in Chapter 3 
or Chapter 4 of your JADE Installation and Configuration Guide, respectively) are correctly defined.   

The batch Dump and Load utility program parameters are described in the following subsections.  
(For more details, see “Running the Dump and Load Utility”, earlier in this document.) 

action 
The action command specifies the type of action that you want to perform on your user data.  The 
valid entries are dump or load. 

transferDir 
The transferDir parameter specifies the path to which your user data files are written during the 
dump process or from which they are read during the load process.   

The transfer directory must exist. 

path 
The path parameter specifies the path of your JADE database directory from which your user data 
files are read during a dump action or to which they are written during a load action.   
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The database path must exist, and the target database into which transferred data is loaded cannot 
contain existing user data. 

ini 
The optional ini parameter enables you to specify the fully qualified name of your JADE 
initialization file if it is not located in the database directory specified in the path parameter or it 
has a file name other than the jade.ini default.   

server 
The optional server parameter enables you to specify the mode in which the dump or load 
operation is to be actioned; that is, singleUser or remoteSingleUser.   

By default, your user data is dumped in singleUser mode; that is, local, single user mode. 

displayTimes 
The optional displayTimes parameter enables you to specify that you do not want date and time 
information output with messages to stdout or stderr.   

When you specify this parameter with a value of false, date and time information is not output with 
errors and warnings. 

By default, dates and times are output; that is, a value of true is assumed. 

help 
The optional help parameter displays the required parameters, their values, and a brief 
explanation of each parameter. 
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