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Before You Begin 

____________________________________  

The JADE Remote Node Access Utility User’s Guide is intended as the main source of information when 
you start or administer JADE on a server node.   

Who Should Read this Guide  
The main audience for the JADE Remote Node Access Utility User’s Guide is expected to be system 
administrators.   

Terminology 
In this document, the term Microsoft Windows refers to Windows 2003 Server, Windows Vista, 
Windows XP, Windows 2000, or Windows CE.  When there are differences between the versions of 
Microsoft Windows, the specific version of Microsoft Windows is stated.  This also applies to Linux, 
which is a specific version of UNIX developed by SUSE or Red Hat.  The term UNIX is used when 
an issue is generic to all versions of UNIX and the term Linux is used if the issue is specific to the 
SUSE or Red Hat implementation of UNIX.   

With the exception of the jade.exe program, when referring to Windows program executables in 
this document, the .exe file suffix is omitted; for example, jadclient refers to jadclient.exe on 
Windows and jadclient.sh on UNIX.  Similarly, the Windows .dll (Dynamic Link Library) and 
UNIX .so (shared object library) file suffixes are omitted.  For example, jomos refers to jomos.dll 
(Windows) and libjomos.so (Linux). 

Related Documentation 
Other documents that are referred to in this guide, or that may be helpful, are listed in the 
following table, with an indication of the JADE operation or tasks to which they relate.   

Title Related to… 

JADE Development Environment Administration Guide Administering the JADE development environment 

JADE Synchronized Database Service (SDS) Administration Guide Administering JADE Synchronized Database Services (SDS), 
 including Relational Population Services (RPS) 

JADE Object Manager Guide JADE Object Manager administration, including security 

JADE Installation and Configuration Guide Installing and configuring JADE 

JADE Initialization File Reference Maintaining JADE initialization file parameter values 
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Conventions  
The JADE Remote Node Access Utility User’s Guide uses consistent typographic conventions 
throughout. 

Convention Description 

Arrow bullet ( ) Step-by-step procedures.  You can complete procedural instructions by using either the mouse or the 
keyboard. 

Bold Items that must be typed exactly as shown.  For example, if instructed to type foreach, type all the 
bold characters exactly as they are printed. 

 File, class, primitive type, method, and property names, menu commands, and dialog controls are also 
shown in bold type, as well as literal values stored, tested for, and sent by JADE instructions. 

Italic Parameter values or placeholders for information that must be provided; for example, if instructed to 
enter class-name, type the actual name of the class instead of the word or words shown in italic type. 

 Italic type also signals a new term.  An explanation accompanies the italicized type. 

 Document titles and status and error messages are also shown in italic type. 

Blue text Enables you to click anywhere on the cross-reference text (the cursor symbol changes from an open 
hand to a hand with the index finger extended) to take you straight to that topic.  For example, click on 
the “JADE Server Node and Multithreading” cross-reference to display that topic.   

Bracket symbols ( [ ] )  Indicate optional items. 

Vertical bar ( | )  Separates alternative items. 

Monospaced font Syntax, code examples, and error and status message text. 

ALL CAPITALS Directory names, commands, and acronyms. 

SMALL CAPITALS Keyboard keys. 

Key combinations and key sequences appear as follows. 

Convention Description 

KEY1+KEY2 Press and hold down the first key and then press the second key.  For example, “press SHIFT+F2” 
means to press and hold down the SHIFT key and press the F2 key.  Then release both keys. 

KEY1,KEY2 Press and release the first key, then press and release the second key.  For example, “press ALT+F,X” 
means to hold down the ALT key, press the F key, and then release both keys before pressing and 
releasing the X key. 
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Chapter 1    Using the JADE Remote Node Access Utility 

____________________________________  

This document covers the following topics.   

 Overview 

 JADE Server Node and Multithreading 

 Installing the JADE Remote Node Access Utility 

 Executing the JADE Remote Node Access Utility 

 Administering the JADE Remote Node Access Utility 

 Clearing the JADE Server Node Window Display 

 Disabling Users from Signing On 

 Minimizing or Restoring the JADE Server Node Window 

 Synchronizing Non-GUI Server Application Cached Details 

 Starting a Service 

 Stopping a Service 

 Exiting from the JADE Remote Node Access Utility 

 Maintaining Your Network Communications Protocol 

 Specifying Your Server Node Name 

 Configuring Your TCP/IP Network Connections 

 Specifying Your JADE Remote Node Access Utility Options 

 Running the Server Node as a Service 

 Configuring Your Server Node Threads 

 Obtaining Online Help for the JADE Remote Node Access Utility 

 Accessing the Online Help Contents 

 Displaying JADE Remote Node Access Version Information 
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Overview 
The JADE Remote Node Access utility ( jadrap) is a user interface that enables you to start or 
administer JADE on a server node.  You can use this utility to:   

 Access a JADE database on the server node in multiuser mode 

 Enable, disable, or configure a TCP/IP communications protocol 

 Configure the threads on the server node for the JADE database   

 Configure the server node as a Windows 2003 Server, Windows Vista, Windows XP, or 
Windows 2000 service 

When services are installed or removed, entries in the HKEY_LOCAL_MACHINE (HKLM) 
area of the registry must be modified but standard Vista users do not have the necessary 
privileges to do this.   

Note    This is also an issue on Windows XP when running as a standard user. 

The menu options that enable the JADE Remote Node Access utility to run as a service are 
disabled if you do not have the necessary privileges to install or remove an application as a 
service.  Installing, controlling, and removing a service can be performed only if you have 
sufficient operating system privileges. 

 Synchronize cached values when you have modified non-GUI server application details in the 
JADE initialization file 

In a multiuser environment, the JADE Remote Node Access utility can be accessed only from the 
server node.  A client node can therefore not use a specific JADE database until that database has 
been accessed on the server node, by using the JADE Remote Node Access utility.  (The JADE 
Remote Node Access utility has no meaning in single user mode, as the client and server nodes are 
the same node.) 

Each JADE database in multiuser mode must have its own JADE Remote Node Access utility, 
regardless of the server workstation on which it is running; that is, one server workstation may have 
one or more JADE Remote Node Access utilities.   

Client nodes in a multiuser JADE environment can connect to the server node by using the 
TCP/IP communications protocol. 

JADE Server Node and Multithreading 
Server node threads perform server node request processing.  (Each application running in JADE 
is executed on its own thread and each thread effectively runs as a standalone Windows program.) 

The JADE Remote Node Access utility provides flexibility in configuring a multiuser JADE 
application environment by enabling you to specify the: 

 Minimum number of server node threads 

 Maximum number of notification threads 

 Server thread priority 

This provides an application administrator with full control of how much resource the server node 
can use and when new resource is activated.   
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When a non-GUI application thread fails to respond within 45 seconds, JADE attempts to interrupt 
the processing of that thread, waits for another 10 seconds, and then terminates the thread.  See 
also “Note about Shutting Down a Database Server Node”, in the following subsection. 

Notes   Active users are calculated from the total of all JADE application instances on all JADE 
client nodes plus one additional system user for each JADE client node.  For example, running 
one JADE development client node counts as two active users; that is, one for the JADE 
development application and one for the system user.  Similarly, a client node running a deployed 
JADE application counts as two active users.  If both these JADE client nodes run at the same time, 
you use a total of four active users.  However, when running the same deployed JADE application 
from within another JADE application (for example, the development environment), you use two 
users for JADE application instances plus one system user, totaling three. 

Boosting the thread priority may have negative side effects on other applications and the Windows 
desktop environment when JADE threads become CPU-intensive (or loop, for some reason). 

JADE’s flexible approach to distributed processing provides scalable applications that maximize the 
utilization of the available hardware resources.  A scalable system enables you to minimize potential 
bottlenecks, both physical and logical. 

Two or more processes can communicate independently with the server node, as there is one 
logical connection for each node process. 

Notes   The maximum number of server methods that can execute concurrently is one fewer than 
the number of threads available on the server node. 

If an exception handler is armed in the executing node and an exception is raised, it is handled in 
the executing node.  If no exception handler is armed in the executing node, the exception is 
reported back to the invoking node for exception handling. 

Note about Shutting Down a Database Server Node 
When you shut down a database server node (that is, jadrap or jadserv on Windows or jaded on 
UNIX) and there are database transactions still in progress, these incomplete transactions must be 
aborted.   

You can determine whether transactions are in progress by using the JADE Monitor. 

The server control program waits up to 45 seconds for each server thread to terminate.  However, a 
server thread may be processing a lengthy operation such as returning deleted object space to the 
freespace index, which may take longer than 45 seconds to complete in some situations.   

If the server control program finalizes the database while a user updating operation is still in 
progress, it is not safe to continue and a fatal exception is raised, resulting in the abrupt 
termination of the database server.  Subsequent restart recovery will undo the incomplete 
transaction.   

When this scenario is detected, the following messages are recorded in the jommsg.log file. 

PDB:clearing active user: [3] <user3> during finalise 
PDB:user: [3] <user3> has active thread in database engine 
PDB:*** unexpected sign off while database operation still active for [3] 
user3 
PDB:*** thread state not known, database server must terminate to force 
restart recovery 
PDB:*** Terminating process now .......  
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In the simple case when the database is finalized and users have been left signed on with 
incomplete transactions but they do not have pending update operations in progress, the following 
messages are recorded in the jommsg.log file. 

PDB: clearing active user: [6] <user6> during finalise 
PDB: [6] <user6> unexpected sign off while in transaction state 
PDB: [6] <user6> aborting overflowed transaction 1293682... 

In this situation, if the transaction abort is allowed to complete, the database will be closed 
normally. 

Physical Bottlenecks 
Physical bottlenecks occur when hardware resources are exhausted in a workstation due to work 
overload.  Physical bottlenecks are common on a centralized system in which a specific workstation 
handles a disproportionate amount of the total system workload.   

JADE enables you to build scalable systems, by allowing the distribution of the workload among 
client and server workstations in a flexible manner.  Client and server workstations host 
heterogeneous nodes that can potentially perform any of the system’s tasks.   

In JADE, clients can execute not only presentation code and application logic, but also a large part 
of the data management functions that otherwise have to be carried out by the server node.   

Transaction processing in JADE is divided into client node transaction tasks and server node 
transaction tasks.  The server node transaction tasks are thus reduced to those that it is strictly 
necessary for the server node to perform; for example, concurrency control and transaction 
recovery.   

Most of the index processing and update consolidation for objects takes place in the client node 
that originated the transaction. 

Logical Bottlenecks 
Logical bottlenecks occur when there is frequent contention for logical global resources because of 
the nature of the system.  Logical bottlenecks can occur both in a centralized and in a 
decentralized system.  The system design characteristics can help to reduce it, depending on the 
amount of flexibility provided by the development tools that are used. 

The flexible JADE data model allows the definition of relatively small indexes and collection.  
Working with smaller and independent units of data reduces the potential for logical bottlenecks.  

When logical bottlenecks are avoided, more work can be done in parallel by more nodes in the 
system and the net effect is that the system can handle larger volumes of transactions. 

When a new client node is added to a JADE network, the node brings with it its computational 
power, which reduces the requirements of the central server for each client node.  This condition 
increases the number of client nodes, each performing a significant amount of work that can 
participate in a JADE network. 

Installing the JADE Remote Node Access Utility 
The JADE Remote Node Access utility is installed in the directory in which your JADE binary files 
are located (for example, c:\ jade\bin) as part of the JADE installation process.  You can install 
multiple copies of JADE on a server, each one having its own database and associated JADE 
Remote Node Access utility and JADE initialization file. 
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Note   Ensure that the correct path is specified in the command line for each JADE Remote Node 
Access utility that you install; for example: 

 jadrap path=c:\jade\data ini=c:\jade\system\jade.ini 

For details about installing and configuring JADE in a multiuser environment, see “Installing Your 
JADE Software” and “JADE Configurations under Windows”, in Chapter 1 of your JADE Installation 
and Configuration Guide and for details about the parameters in the JADE initialization file that 
affect the operation of the JADE server, see “JADE Object Manager Server Section [ JadeServer]”, 
in your JADE Initialization File Reference. 

Executing the JADE Remote Node Access Utility 
You can execute the JADE Remote Node Access utility to initiate a JADE database only from the 
server workstation. 

 To execute the JADE Remote Node Access utility, perform one of the following actions 

 Click the JADE Remote Node Access icon in your JADE program folder for the appropriate 
JADE database.  (As a JADE server workstation can have many databases, the server may have 
many JADE program folders.) 

 In Explorer or File Manager, access the directory in which your JADE binary files are located 
(for example, c:\ jade\bin) and then double-click on the jadrap program file. 

The JADE server node window, shown in the following diagram, is then displayed.   

 

Users on client nodes can now access the JADE database. 

Tip   The title bar of the JADE server node window displays the node name, the path of the JADE 
database on the server node, and the configured transport protocol, to enable you to differentiate 
between the JADE databases on the server workstation. 

Use the menu bar to access the JADE Remote Node Access utility commands. 
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Administering the JADE Remote Node Access Utility 
Use the File menu in the JADE server node window to perform one of the administrative actions 
listed in the following table. 

Command  Description For details, see…  

Clear Display Clears contents from the JADE server node  Clearing the JADE Server Node Window Display 
 window  

Disable User SignOn Stops users signing on to JADE in a multiuser Disabling Users from Signing On 
 environment  

Use System Tray Icon Automatically minimizes the JADE Remote Minimizing or Restoring the JADE Server Node Window 
 Node Access utility as an icon in the system  
 tray after start up or toggles the minimizing  
 or restoring of the utility 

Synch Server Apps Synchronizes the non-GUI server application Synchronizing Non-GUI Server Application Cached Details  
 details in caches 

Start Service Starts the JADE Remote Node Access utility Starting a Service 
 as a service 

Stop Service Stops running the JADE Remote Node Access Stopping a Service  
 utility as a service 

Exit Exits from the JADE server, and closes the Exiting from the JADE Remote Node Access Utility  
 JADE database 

Clearing the JADE Server Node Window Display 
The Clear Display command from the File menu enables you to clear the contents from the JADE 
server node window, if required.   

 To clear the window contents 

 If you no longer want the contents displayed in the JADE server node window, select the 
Clear Display command from the File menu. 

The window contents are then removed from the JADE server node window. 

Disabling Users from Signing On 
The Disable User SignOn command from the File menu enables you to disable users from signing 
on to the JADE database; for example, when you want to back up the database on the server node.   

 To disable users from signing on 

 If you do not want any more users to sign on to the JADE database, select the Disable User 
SignOn command from the File menu. 

A check mark ( ) is then displayed to the left of the command in the File menu, indicating that 
user sign on is currently disabled.  Any user who then tries to sign on to the JADE database is 
unable to do so and an exception is raised on the remote node at which the sign on was attempted. 

 To allow users to sign on to the JADE database 

 Select the Disable User SignOn command from the File menu. 
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The check mark ( ) is then removed from the left of the menu command and remote users can 
then sign on the database again. 

Minimizing or Restoring the JADE Server Node Window 
By default, the JADE server node window is automatically minimized and an icon is placed in the 
system tray when the JADE Remote Node Access utility starts up.   

The Use System Tray Icon command from the File menu enables you to toggle the minimizing or 
restoring of the JADE server node window to or from the system tray icon.  When the window can 
be automatically minimized and a system tray icon displayed in the Taskbar (the default value), a 
check mark ( ) is displayed to the left of the command in the File menu and an icon is placed in 
the system tray in the Taskbar at the lower right of the screen when the utility starts up.   

The icon is removed from the system tray when the JADE Remote Node Access utility closes down 
or the use of the system tray icon is disabled. 

 To toggle the use of the system tray icon 

 Click the Use System Tray Icon from the File menu.   

When the use of the system tray icon is activated, a check mark ( ) is displayed to the left of the 
command in the File menu and an icon is placed in the system tray at the lower right of the screen 
when the utility starts up.   

When you disable the use of the system tray icon for the utility, no check mark is displayed at the 
left of the command in the File menu, no icon is located in the system tray, and the window is not 
automatically minimized when the application starts up. 

In addition, the UseSystemTrayIcon parameter in the [ JadeServer] section of the JADE 
initialization file is updated to maintain the current value for future work sessions when you exit 
from the utility.  For details, see the “UseSystemTrayIcon” parameter under “JADE Object Manager 
Server Section [ JadeServer]”, in your JADE Initialization File Reference. 

When you move the mouse over the icon, bubble help is displayed that contains the information 
displayed in the title bar of the JADE server node window; that is, the node name, the path of the 
JADE database on the server node, and the configured transport protocol.  This information, 
which enables you to differentiate between the JADE databases on the server workstation, is 
truncated to 63 characters in the bubble help, if applicable.   

 To restore the JADE server node window 

 Left-click on the JADE Remote Node Access utility icon in the system tray at the right of the 
Taskbar. 

The JADE server node window is then restored (that is, maximized). 

 To minimize the window again when the use of the system tray icon is enabled 

 Left-click on the JADE Remote Node Access utility icon in the system tray again. 

The JADE server node window is then minimized; that is, left-clicking on JADE Remote Node 
Access utility icon in the system tray toggles the minimizing and restoring of the JADE server node 
window. 
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 To access the JADE Remote Node Access utility system tray icon menu 

 Right-click on the JADE Remote Node Access utility icon in the system tray at the right of the 
Taskbar. 

The system tray icon menu for the utility is then displayed.   

The JADE Remote Node Access utility icon menu provides the following commands. 

 Minimize / Restore 

The Minimize or Restore command, determined by the current status of the JADE server 
node window, toggles the minimizing or restoring of the JADE server node window. 

 Disable User SignOn 

The Disable User SignOn command stops users signing on to JADE in a multiuser 
environment.  For details, see “Disabling Users from Signing On”, earlier in this document. 

 Use System Tray Icon 

The Use System Tray Icon command enables or disables the automatic minimizing of the 
JADE server node window when the application starts up and placement of the JADE Remote 
Node Access utility icon in the system tray.   

Tip   Select this command from the icon menu if you want to disable the use of the system 
tray icon and automatic minimizing of the JADE server node window.  The icon is then 
removed from the system tray.  (When use of the system tray icon is disabled, you can enable 
it at any time by selecting the Use System Tray Icon command in the File menu of the JADE 
server node window.) 

The UseSystemTrayIcon parameter in the [ Jade] section of the JADE initialization file 
enables you to configure whether the interrupt icon is positioned in the system tray. 

 Sync Server Apps 

The Sync Server Apps command synchronizes the non-GUI server application details in 
caches.  For details, see “Synchronizing Non-GUI Server Application Cached Details”, later in 
this document. 

 Exit 

The Exit command exits from the JADE server and closes the JADE database.  For details, 
see “Exiting from the JADE Remote Node Access Utility”, later in this document. 

Synchronizing Non-GUI Server Application Cached Details 
If you add or remove a ServerApplication<application-number> parameter in the [ JadeAppServer]  
or [ JadeServer] section of your JADE initialization file or you change any variable values after the 
server has started, select the Synch Server Apps command from the JADE Remote Node Access 
utility File menu. 

JADE then reads all ServerApplication<application-number> parameters in the JADE initialization 
file and caches the changed values.  Use this command if you have changed the time at which a 
non-GUI server application is started or you have specified a new non-GUI server application to 
start at a specific time, for example. 
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Starting a Service 
Use the Start Service command from the File menu to start running the JADE server node as a 
service.   

 To start running the server node as a service 

1. Ensure that the Run Server as Service check box in the Service Configuration dialog is 
checked.  (For details, see “Running the Server Node as a Service”, later in this document.) 

2. Select the Start Service command from the JADE server node window File menu.  This 
command is disabled if the server node is not configured to run as a service or it is currently 
running as a service. 

A message dialog then informs you that the service has successfully started.   

Notes   As services are supported only by Windows 2003 Server, Windows Vista, Windows XP, and 
Windows 2000, this command is enabled only if you are running JADE under a Windows operating 
system that supports services (and the server node is currently configured as a service). 

When services are installed or removed, entries in the HKEY_LOCAL_MACHINE (HKLM) area of 
the registry must be modified but standard Vista and Windows XP users do not have the necessary 
privileges to do this.  The menu options that enable the JADE Remote Node Access utility to run 
as a service are disabled if you do not have the necessary privileges to install or remove an 
application as a service.  Installing, controlling, and removing a service can be performed only if 
you have sufficient operating system privileges. 

Stopping a Service 
Use the Stop Service command from the File menu to stop running the JADE server node as a 
service. 

 To stop running the server node as a service 

 Select the Stop Service command from the JADE server node window File menu.  This 
command is disabled if the server node is not currently running as a service. 

The JADE Remote Node Access service is then stopped.   

Notes   As services are supported only by a Windows operating system that supports services this 
command is enabled only if you are running JADE under a Windows operating system that 
supports services (and the server node is currently running as a service). 

When services are installed or removed, entries in the HKEY_LOCAL_MACHINE (HKLM) area of 
the registry must be modified but standard Vista and Windows XP users do not have the necessary 
privileges to do this.  The menu options that enable the JADE Remote Node Access utility to run 
as a service are disabled if you do not have the necessary privileges to install or remove an 
application as a service.  Installing, controlling, and removing a service can be performed only if 
you have sufficient operating system privileges. 
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Exiting from the JADE Remote Node Access Utility 
Use the Exit command from the File menu to exit from the JADE Remote Node Access utility and 
close the JADE database.   

 To exit from the JADE Remote Node Access utility 

 Select the Exit command from the File menu. 

The JADE server node window and the JADE database are then closed.   

If any client nodes are accessing the server node at the time that you select the Exit command, a 
message box advises you that client nodes are still connected, and asks you to confirm that you 
want to exit from the server node. 

When you confirm that you want to exit, any connected clients are immediately disconnected, and 
the server node is then closed down.  If the system tray icon was in use (the default), the icon is 
removed from the system tray when the JADE Remote Node Access utility closes down. 

Note   If the server node is shut down because of a user signing off as an operating system user and 
that user does not confirm that the JADE Remote Node Access utility is to be closed when JADE 
users are still connected to the server, the sign off from the operating system is aborted.  

If you have changed your configuration to run the server node from a server to a service, the 
service is started after the server has disconnected from the database. 

Maintaining Your Network Communications Protocol 
Use the Network menu in the JADE server node window to specify or maintain your 
communications protocol (that is, TCP/IP) or your server node name.   

The Network menu commands are listed in the following table. 

Command  For details, see… Description  

Node Name Specifying Your Server Node Name Displays the Node Name dialog 

TcpIp Configuring Your TCP/IP Network Connections Displays the TcpIp Network dialog 

For details, see the following subsections. 

Specifying Your Server Node Name 
Use the Node Name command from the Network menu to configure your server node name. 

 To configure your server node name 

1. Select the Node Name command from the Network menu. 
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The Node Name dialog, shown in the following diagram, is then displayed. 

 

2. For a TCP/IP network connection, specify the unique name of your JADE database server 
node in the Node Name text box.  (The default value is JadeServerNode.) 

Each JADE database must have a unique node name. 

3. Click the OK button. 

Alternatively, click the Cancel button to abandon your selections. 

The NodeName parameter in the [ JadeServer] section of the JADE initialization file is then 
updated and focus returns to the JADE server node window. 

The server node name is displayed in the JADE Remote Node Access utility title bar.  As each 
JADE database has its own JADE Remote Node Access utility, you can use this node name to 
differentiate between the JADE databases in your server workstations. 

Configuring Your TCP/IP Network Connections 
Use the TcpIp command from the Network menu to configure your TCP/IP network connection.  
(For details about TCP/IP addresses, see “Selecting Network Addresses”, in Chapter 5 of your 
JADE Installation and Configuration Guide.) 

 To configure your TCP/IP network connection 

1. Select the TcpIp command from the Network menu.  The TcpIp Network dialog, shown in 
the following diagram, is then displayed. 

 

2. To add a new TCP/IP network connection, click the Add button. 



JADE Remote Node Access Utility  
User’s Guide 

Chapter 1    Using the JADE Remote Node Access Utility  17 

JadRap-6.3 

The TcpIp Network Entry dialog, shown in the following diagram, is then displayed. 

 

In the TcpIp Network Entry dialog, specify your TCP/IP network, as follows. 

a. Uncheck the Entry enabled check box if you want to temporarily disable the network 
specification without having to renumber the unique identifiers of any other 
NetworkSpecification<specification-number> parameters in your [ JadeServer] section of 
your JADE initialization file.  The TCP/IP communications protocol is enabled by 
default. 

b. In the Listener port text box, specify the listener port number from which TCP/IP 
accepts connections.  (The default value is 6005.) 

Select a unique port number.  Each JADE database on the server must have a unique 
server port number in the range 1024 through the maximum value for the workstation, 
which is usually 65,534. 

c. The Interface combo box enables you to specify a specific network interface from which 
TCP/IP accepts connections if you want to restrict the JADE server from accepting 
connections from all network adapters.  By default, JADE listens on all local network 
adapters; that is, all interfaces are selected. 

If you are running JADE under a Windows operating system that supports services, you 
can select a local interface from the Interface combo box.  Alternatively, you can specify 
a local interface in the Interface text box by TCP/IP name or by IP address.  (Use the 
ipconfig/all command prompt to display all Ethernet Adapter IP addresses on the 
current node, if required.)   

d. Click the OK button to add the TCP/IP network connection.  Alternatively, click the 
Cancel button to abandon your selections.   

The specified connection is then displayed under the Listener port, State, and Interface 
headings in the TcpIp Network dialog.   

A corresponding NetworkSpecification<specification-number> parameter is added to the  
[ JadeServer] section of your JADE initialization file when you click the OK button in the 
TcpIp Network dialog.  (Each new network specification number is incremented by one.) 

3. To edit an existing TCP/IP network specification, select the specification that you want to 
change and then click the Edit button. 

The TcpIp Network Entry dialog is then displayed, to enable you to make the changes to the 
listener port, connection state, and interface that you require.   

Click the OK button to update the information for that TCP/IP network connection or click 
the Cancel button to abandon your selections.  The amended TCP/IP network connection is 
then displayed under the appropriate headings in the TcpIp Network dialog.   
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4. To remove an existing TCP/IP network specification, select the specification that you want to 
delete and then click the Remove button. 

The selected network specification is then removed from the list. 

5. When you have maintained all TCP/IP network connections that you require, click the OK 
button.  All NetworkSpecification<specification-number> parameters are then updated in the 
[ JadeServer] section of your JADE initialization file.  Alternatively, click the Cancel button to 
abandon your selections. 

6. Restart the JADE Remote Node Access utility or the service to bring your changes into effect. 

For more details, see “NetworkSpecification<specification-number>” under “JADE Object Manager 
Server Section [ JadeServer]”, in your JADE Initialization File Reference. 

Specifying Your JADE Remote Node Access Utility Options 
Use the Options menu in the JADE server node window to specify or maintain your server node 
threads or to run the server node as a service.  For details about multiple threads, see “JADE Server 
Node and Multithreading”, earlier in this document. 

Note   An increase in the number of threads uses more resource, which may be limited by the 
amount of memory on your server or the available CPU. 

The Options menu commands are listed in the following table. 

Command For details, see… Description  

Service Running the Server Node as a Service Displays the Service Configuration dialog 

Threads Configuring Your Server Node Threads Displays the Thread Configuration dialog 

For details, see the following subsections.   

Running the Server Node as a Service 
Use the Service command from the Options menu to configure your server node as a service. 

Notes   As services are supported only by Windows 2003 Server, Windows Vista, Windows XP, and 
Windows 2000, this command is disabled if you do not have Windows permission to change the 
service configuration. 

When services are installed or removed, entries in the HKEY_LOCAL_MACHINE (HKLM) area of 
the registry must be modified but standard Vista and Windows XP users do not have the necessary 
privileges to do this.  The menu options that enable the JADE Remote Node Access utility to run 
as a service are disabled if you do not have the necessary privileges to install or remove an 
application as a service.  Installing, controlling, and removing a service can be performed only if 
you have sufficient operating system privileges. 

When you run the JADE Remote Node Access utility as a service, the service is started 
automatically when the server workstation is started up, to enable client nodes to access that JADE 
database.  (When the utility is run as a server node, it must be started from the JADE Remote 
Node Access shortcut or the JADE Remote Node Access icon in your JADE program folder on the 
server node to initialize the JADE database before client nodes can use that database.) 
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You can use the Windows 2003 Server, Windows Vista, Windows XP, or Windows 2000 Control 
Panel Services window to specify that the service is started manually or the Start Service command 
from the JADE server node window File menu.  (For details, see “Starting a Service”, earlier in this 
document.)   

When a service is to be started manually, client nodes cannot access the database until the service is 
started, even if the server workstation is started up. 

 To configure your server node as a service 

1. Select the Service command from the Options menu.  The Service Configuration dialog, 
shown in the following diagram, is then displayed. 

 

2. Check the Run Server as Service check box if you want the server node to be run as a service. 

By default, a server node is not run as a service; that is, this check box is unchecked. 

3. Click the OK button.  Alternatively, click the Cancel button to abandon your selection. 

The service is then installed and registered in the Windows 2003 Server, Windows Vista, 
Windows XP, or Windows 2000 registry, the service with the name of the server node (for 
example, DevSvrNode_12) is created in automatic start-up mode, and the RunAsService 
parameter in the [ JadeServer] section of your JADE initialization file is set to true. 

4. Select the Exit command from the File menu to close the JADE server node window and the 
JADE database.  The JADE service is then started.   

When the JADE Remote Node Access utility is run as a service, that service is connected to the 
database.  To access the utility as a server node for administrative purposes only, double-click the 
JADE Remote Node Access shortcut or click the JADE Remote Node Access icon in your JADE 
program folder on the server node when the service is running.  (In administration mode, you 
cannot connect to the database, as that connection is currently used by the service.)   

Note   Any changes that you make in administration mode update your JADE initialization file but 
do not update the service until that service is closed and then restarted.  (To close a service, select 
the service from the Windows Control Panel Services utility window and then click the Stop 
button.) 

The JADE server node window is not displayed when the server node is running as a service.  To 
maintain your communications protocol or server threads, or to specify that you want to run the 
utility as a server, you must access the JADE server node window by running the JADE Remote 
Node Access utility as a server node. 

Resetting a Service to a Server Node 
If you no longer want to run the server node as a service, you must reset the JADE Remote Node 
Access utility in the administration mode. 
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 To configure your service as a server node 

1. Double-click the JADE Remote Node Access shortcut or click the JADE Remote Node 
Access icon in your JADE program folder on the server node when the service is running. 

The JADE server node window is then displayed.   

2. Select the Service command from the Options menu. 

The Service Configuration dialog is then displayed. 

3. Uncheck the Run Server as Service check box, to specify that the server node is to run as a 
server. 

4. Click the OK button.  Alternatively, click the Cancel button to abandon your selection. 

The service is then stopped and deregistered from the Windows 2003 Server, Windows Vista, 
Windows XP, or Windows 2000 registry.  The RunAsService parameter in the [ JadeServer] 
section of your JADE initialization file is set to false. 

5. Select the Exit command from the File menu to close the JADE server node window and the 
JADE database. 

6. Restart the server node by double-clicking the JADE Remote Node Access shortcut or 
clicking the JADE Remote Node Access icon in your JADE program folder on the server 
node, to initialize the JADE database before client nodes can use that JADE database.   

Configuring Your Server Node Threads 
Use the Threads command from the Options menu to configure your server threads. 

 To configure or maintain your server threads 

1. Select the Threads command from the Options menu.   

The Thread Configuration dialog, shown in the following diagram, is then displayed. 

 

2. In the Minimum Server Threads text box, specify the minimum number of threads that you 
require for the JADE database on this server.  The minimum number of threads is 1 and the 
default value is 20. 

3. In the Maximum Server Threads text box, specify the maximum number of threads that you 
require for the JADE database on this server.  The default value is 100. 
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4. In the Maximum Notification Threads text box, specify the maximum number of threads that 
are required to deliver notifications to users on client nodes.  The default value is 5. 

5. Use the Default thread priority slider to select the priority of threads on the server if you do 
not want the default priority of Normal to be used.   

The priority can be set to Lowest, Low, Normal (the default), High, or Highest. 

Note   Boosting the thread priority may have negative side effects on other applications and 
the Windows desktop environment when JADE threads become CPU-intensive (or loop, for 
some reason). 

6. Click the OK button.  Alternatively, click the Cancel button to abandon your selections. 

The JADE initialization file parameters listed in the following table are then updated, and focus 
returns to the JADE server node window. 

Parameter Section Default 

MinServerThreads [JadeServer] 20 

MaxServerThreads [JadeServer] 100 

MaxNotifyThreads [JadeServer] 5 

ThreadPriority [JadeServer] Normal 

Obtaining Online Help for the JADE Remote Node Access Utility 
Use the Help menu in the JADE server node window to perform one of the actions listed in the 
following table. 

Command  For details, see… Description  

Index Accessing the Online Help Contents Opens the online help in Adobe Reader 

About JadRap Displaying JADE Remote Node Access Version Information Displays version information for the JADE Remote  
  Node Access utility 

Accessing the Online Help Contents 
Use the Index command from the JADE Remote Node Access utility Help menu to open online 
help.  The online help window in Adobe Reader displays a table of contents down the left, to 
enable you to select the online help topic about which you require assistance. 

 To access the online help, perform one of the following actions 

 Select the Index command from the Help menu 

 Press F1 when the focus is on the JADE server node window. 

The JADE online help window is then displayed in Adobe Reader. 

For details about using JADE online help, see “JADE Product Information Library in Portable 
Document Format”, in Chapter 2 of your JADE Development Environment User's Guide. 
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Displaying JADE Remote Node Access Version Information 
Use the About JadRap command from the Help menu to display version (and copyright) 
information for the JADE Remote Node Access utility.   

 To display version information 

 Select the About JadRap command from the Help menu. 

The version and copyright information for the JADE Remote Node Access utility are then 
displayed.   

When you have viewed the version information, click the OK button to close the dialog and return 
focus to the JADE server node window.   
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