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Before You Begin 

____________________________________  

The JADE Schema Inspector Utility User’s Guide is intended as the main source of information when 
you inspecting JADE database objects in production systems. 

Who Should Read this Guide  
The main audience of the JADE Schema Inspector Utility User’s Guide is expected to be system 
administrators.   

Terminology 
In this document, the term Microsoft Windows refers to Windows 2003 Server, Windows Vista, 
Windows XP, Windows 2000, or Windows CE.  When there are differences between the versions of 
Microsoft Windows, the specific version of Microsoft Windows is stated.  This also applies to Linux, 
which is a specific version of UNIX developed by SUSE or Red Hat.  The term UNIX is used when 
an issue is generic to all versions of UNIX and the term Linux is used if the issue is specific to the 
SUSE or Red Hat implementation of UNIX.   

With the exception of the jade.exe program, when referring to Windows program executables in 
this document, the .exe file suffix is omitted; for example, jadclient refers to jadclient.exe on 
Windows and jadclient.sh on UNIX.  Similarly, the Windows .dll (Dynamic Link Library) and 
UNIX .so (shared object library) file suffixes are omitted.  For example, jomos refers to jomos.dll 
(Windows) and libjomos.so (Linux). 

Related Documentation 
Other documents that are referred to in this guide, or that may be helpful, are listed in the 
following table, with an indication of the JADE operation or tasks to which they relate.   

Title Related to… 

JADE Database Administration Guide Administering a JADE database 

JADE Development Environment Administration Guide Administering the JADE development environment 

JADE Development Environment User’s Guide Using the JADE development environment to development JADE 
applications 

JADE Initialization File Reference Maintaining JADE initialization file parameter values 

JADE Installation and Configuration Guide Installing and configuring JADE 

JADE Report Writer User’s Guide Using the JADE Report Writer to develop and run reports 

JADE Runtime Application Guide Administering JADE deployed runtime applications 

JADE Web Application Guide Implementing, monitoring, and configuring Web applications 
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Conventions  
The JADE Schema Inspector Utility User’s Guide uses consistent typographic conventions throughout. 

Convention Description 

Arrow bullet (¾) Step-by-step procedures.  You can complete procedural instructions by using either the mouse or the 
keyboard. 

Bold Items that must be typed exactly as shown.  For example, if instructed to type foreach, type all the 
bold characters exactly as they are printed. 

 File, class, primitive type, method, and property names, menu commands, and dialog controls are also 
shown in bold type, as well as literal values stored, tested for, and sent by JADE instructions. 

Italic Parameter values or placeholders for information that must be provided; for example, if instructed to 
enter class-name, type the actual name of the class instead of the word or words shown in italic type. 

 Italic type also signals a new term.  An explanation accompanies the italicized type. 

 Document titles and status and error messages are also shown in italic type. 

Blue text Enables you to click anywhere on the cross-reference text (the cursor symbol changes from an open 
hand to a hand with the index finger extended) to take you straight to that topic.  For example, click on 
the “Using the Schema Inspector Window” cross-reference to display that topic. 

Bracket symbols ( [ ] )  Indicate optional items. 

Vertical bar ( | )  Separates alternative items. 

Monospaced font Syntax, code examples, and error and status message text. 

ALL CAPITALS Directory names, commands, and acronyms. 

SMALL CAPITALS Keyboard keys. 

Key combinations and key sequences appear as follows. 

Convention Description 

KEY1+KEY2 Press and hold down the first key and then press the second key.  For example, “press SHIFT+F2” 
means to press and hold down the SHIFT key and press the F2 key.  Then release both keys. 

KEY1,KEY2 Press and release the first key, then press and release the second key.  For example, “press ALT+F,X” 
means to hold down the ALT key, press the F key, and then release both keys before pressing and 
releasing the X key. 
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Chapter 1     Inspecting a Deployed Database 

____________________________________  

This document covers the following topics. 

� Overview 

� Using the Schema Inspector Dialog 

� Using the Schema Inspector Window 

Overview 
The Schema Inspector is supplied with JADE, to enable you to inspect database objects in your 
production JADE systems.   

The Schema Inspector icon is installed in your JADE program folder when you install JADE.   

A security filter method enables you to define security to specify users who can inspect class 
instances in a deployed (run time) database.  For details, see “Deployed JADE Database Inspection 
Security”, in Chapter 3 of your JADE Object Manager Guide. 

Note   At run time, no instances can be inspected if you do not implement the security filter 
method to return true in a deployed system.  This ensures that any user of the Schema Inspector in 
a deployed application can inspect only those classes to which access has been specifically 
permitted by the application software developer. 

The following is an example of the command line required to run the Schema Inspector. 

jade.exe path=s:\jade\system ini=c:\jade\system\jade.ini schema=RootSchema 
app=SchemaInspector  

¾ To execute the deployed Schema Inspector 

1. Click the Schema Inspector icon in the JADE program folder, to run the standalone Schema 
Inspector application.   

The Schema Inspector sign-on form is then displayed.  The user id of your workstation is 
displayed in the User Id text box by default.   

As your password is hidden for security reasons, each character is represented by an asterisk 
(*) character.   

The user id and password are case-sensitive.   

2. Specify your user id and optionally your password in the appropriate text boxes, and then 
click the OK button to sign on to the Schema Inspector.   
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The Schema Inspector dialog, shown in the following diagram, is then displayed. 

 

3. In the Select Schema to inspect combo box, select the schema whose instances you want to 
inspect.  The classes list box is then populated with all classes in the selected schema. 

4. In this list box, select the classes whose instances you want to inspect. 

Tip   As the classes list box is a multiple-selection list box, you can use the SHIFT or CTRL key 
to select a group or range of classes. 

5. When you have selected the required classes, click the OK button.  If security is not set, the 
Schema Inspector is then displayed.  Alternatively, click the Cancel button to abandon your 
selections. 

6. If security is set for a selected class and you do not have sufficient security, a message box is 
displayed, informing you that you do not have sufficient security to inspect instances of the 
specified class.   

Perform one of the following actions. 

� Select another class to which you may have inspection access rights.   

� Select the Logoff command from the File menu to display the Schema Inspector 
sign-on form and specify a user id and password that permit access to the classes whose 
instances you want to inspect. 

� Select the Exit command from the File menu, to close the Schema Inspector. 
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When any security filter requirements have been satisfied, the Schema Inspector window is then 
displayed.  For details about inspecting class instances, see “Using the Schema Inspector Window”, 
later in this document. 

Using the Schema Inspector Dialog 
The Schema Inspector dialog menu bar contains the following menus. 

� File 

� Edit 

� View 

� Help 

Using the File Menu 
Use the File menu in the Schema Inspector dialog to: 

� Exit from the inspector.  (You can also exit from the Schema Inspector dialog by clicking the 
close icon (⌧) at the top right corner of the window or by selecting the Close command 
from the Control-Menu.) 

� Log off from the Schema Inspector when access to class instances is restricted and you want 
to specify another user id and optionally the password. 

¾ To exit from the Schema Inspector dialog 

� Select the Exit command on the File menu.  Alternatively, click the Cancel button. 

The Schema Inspector dialog is then closed. 

¾ To log off from the Schema Inspector dialog 

� Select the Logoff command on the File menu. 

The Schema Inspector sign-on form is then displayed, to enable you to change the user id and 
optionally the password if access to instances of a class is restricted. 

Using the Edit Menu 

¾ To locate a class in the schema hierarchy 

1. Perform one of the following actions. 

� Select the Find command from the Edit menu. 

� Press F4. 

The Find dialog is then displayed. 

2. In the Class to search for: combo box, select the class that you want to locate for subsequent 
inspection. 

3. Click the OK button.  Alternatively, click the Cancel button. 
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Your selected class is then highlighted in the class hierarchy list box of the Schema Inspector 
dialog. 

Using the View Menu 
Although a schema inherits all classes and their associated properties, methods, and constants from 
its superschemas, these inherited classes are not displayed by default in the Schema Inspector 
dialog of the subschema.  Instead, for the sake of clarity, only classes local to the schema are 
displayed, as well as any superschema classes to which subclasses, methods, or constants have been 
added.   

¾ To display superschema classes in the schema hierarchy 

1. Select the Superschemas command from the View menu. 

The View Superschemas dialog is then displayed.  The current schema is displayed in the 
Show classes and methods defined in: combo box, by default. 

2. Select the superschema whose classes you want to display in your Schema Inspector. 

3. When you have selected the appropriate superschema, click the OK button. 

The classes list box of the Schema Inspector dialog is then populated with all of the classes in the 
specified superschema.  (Classes defined in a superschema are displayed in red and those defined 
in the current schema are displayed in black.) 

Using the Help Menu 
Use the commands in the Schema Inspector dialog Help menu to access the standard Common 
User Access (CUA) help options.  These commands are described in the following subsections. 

Index Command 
Use the Schema Inspector dialog Help menu Index command to open the Schema Inspector 
online help.   

The first page of the help document in Adobe Reader displays a table of contents down the left 
side that provides access to the topics available in online help. 

¾ To access the online help, perform one of the following actions 

� Select the Index command from the Help menu 

� Press F1 

The JADE online help is then displayed.   

About Command 
Use the Schema Inspector dialog Help menu About command to access information about the 
Schema Inspector.   

¾ To access the Schema Inspector information 

� Select the About command from the Help menu. 
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The About box is then displayed, providing information about the JADE release, copyright and 
licence information, database path, operating system of the workstation, and the file version (that 
is, ANSI or Unicode).  This dialog is for display purposes only. 

Tip   Double-click the vertical WWW image positioned at the lower right of the JADE About box to 
access the JADE Web site home page (http://www.jadeworld.com/). 

Using the Schema Inspector Window 
The Schema Inspector, shown in the following diagram, is displayed when you have selected a class 
or classes from the deployment Schema Inspector dialog with the appropriate security.   

 

The title bar of the window specifies the number of instances of the selected class.  The left-hand 
list contains an entry for each instance of the selected class.   

¾ To examine each object 

� Select an object in the left-hand list. 

The details for the selected object are then displayed at the right of the Schema Inspector window. 

¾ To inspect a specific object (drill-down) 

� Double-click on an object in the Object List at the left of the Schema Inspector window. 

The specified object and any properties defined for that object are then displayed in a new Schema 
Inspector window. 

http://www.jadeworld.com/
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The specified object and any properties defined for that object are then displayed in a new Schema 
Inspector window.  The Schema Inspector displays the type, name, and dynamic attribute names 
and values of JadeDynamicObject instances. 

¾ To view the values for the current property in the object 

� Click the required property. 

The values for the selected property are then displayed in the pane at the right of the window, as 
shown in the following diagram. 

 

Note   If the current property is a reference or a collection, you can double-click on it to open a 
new inspector window for that property.  This enables you to “drill-down” through your references 
and collections. 

You can inspect the edition or time an object was created, by clicking …edition or …creationTime, 
displayed beneath ***Object*** in the Object List at the left of the Inspector window. 

The Schema Inspector window menu bar contains the following menus: 

� File 

� Options 

� Help 
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Using the File Menu 
Use the File menu in the Schema Inspector window to exit from the deployment inspector.  (You 
can also exit from the Inspector window by clicking the close icon (⌧) at the top right corner of 
the window or by selecting the Close command from the Control-Menu.) 

¾ To exit from the Inspector window 

� Select the Close command on the File menu. 

The Schema Inspector window is then closed. 

¾ To close all open Inspector windows 

� Select the Close All command on the File menu. 

All open Schema Inspector windows are then closed. 

Using the Options Menu 

¾ To specify the font used to display text in the Schema Inspector window 

� Select the Font command from the Options menu if you want to change the default font 
from MS Sans Serif regular 8 points.   

The common Font dialog is then displayed, to enable you to make your font selections.   

When you have selected your required font options, focus is then returned to the Schema 
Inspector window. 

Using the Help Menu 
Use the commands in the Schema Inspector window Help menu to access the standard Common 
User Access (CUA) help options.  These commands are listed in the following subsections. 

Command Description 

Index Opens the Schema Inspector online help, with all topics available in the online help file displayed down the 
left side of the help window in Adobe Reader.   

About Accesses information about the release of the JADE Schema Inspector.  (For details, see “About Command” 
under “Help”, earlier in this document.) 

For details about using JADE online help, see “JADE Product Information Library in Portable 
Document Format”, in Chapter 2 of your JADE Development Environment User's Guide. 
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